Monday, December 16, 2019

the shady world of semalt

it all starts with you seeing a  url pointing to your site . after visitng the url and getting redirected to semalt. if you register on the site . you will immediatly get a whatsapp message from a ukrainian number . but is the guy a ukranian or from pakistan ?

Transworld Associates (Pvt.) Ltd.
Hostname(s) mail.abtach.org
Domain Name tw1.com

it looks like the bosses who run semalt probably hire people in a call center to run their operators?

this all is unverified but this is an experience of a friend .

now once you go to their site . they probably bombard your site with bots hitting your login and xml rpc and keep your stats low hoping you will pay them $$$$ to improve your stats.

jetpack whitelisting and wordfence and events calendar

if you disable xml-rpc and do not white list all the jetpack ip then the event calendar will not load completely

For WordFence under all options , use this: 192.0.[64-127].[1-254]
https://jetpack.com/support/hosting-faq/

to disable xml-rpc in the htaccess use this code

 
 Order Deny,Allow
 Deny from all
 Allow from 122.248.245.244/32
 Allow 54.217.201.243/32
 Allow 54.232.116.4/32
 Allow 192.0.80.0/20
 Allow 192.0.96.0/20
 Allow 192.0.112.0/20
 Allow 195.234.108.0/22
 Allow 192.0.96.202/32
 Allow 192.0.98.138/32
 Allow 192.0.102.71/32
 Allow 192.0.102.95/32
 Satisfy All
 ErrorDocument 403 https://google.com/
 

for some reason after disabling xml-rpc our stats improved . looks like bots were causing some kind of black hat seo via xml rpc ?

Wednesday, December 4, 2019

wordpress error Your Site is Experiencing a Technical Issue after upgrading to upgrading to Jetpack 8.0

Thank you for your email. This was caused by your site's upgrade to Jetpack 8.0. In some cases, upgrading to Jetpack 8.0 will cause an error like this one:

An error of type E_ERROR was caused in line 270 of the file wp-content/plugins/jetpack/vendor/automattic/jetpack-sync/src/Listener.php. Error message: Uncaught Error: Class 'Automattic\Jetpack\Roles' not found in wp-content/plugins/jetpack/vendor/automattic/jetpack-sync/src/Listener.php:270
The error may have been sent to you via an email with the subject line "Your Site is Experiencing a Technical Issue", or it may have displayed in the Plugins page when you tried to update Jetpack.

This happened because we moved some files around in this Jetpack release, which triggers an error when they cannot be found in their old locations. Your site should still have upgraded to Jetpack 8.0, so refreshing the Plugins page in your dashboard should show that version. The error should only happen once, on upgrade, and not after that.

As for the frontend of the site, that should also work fine, though you may want to clear any caches you have just to be sure.