Thursday, January 22, 2015

trying to install the android emulator on linux with genymotion


if you really want to install the android emulator on linux just get the .ova file ,install virtualbox
http://www.linux.org/threads/android-in-virtualbox.6998/

below is my failed attempt to install genymotion.



 sh genymotion-2.3.1_x64_debian.bin
genymotion-2.3.1_x64_debian.bin: 109: genymotion-2.3.1_x64_debian.bin: [[: not found
genymotion-2.3.1_x64_debian.bin: 115: genymotion-2.3.1_x64_debian.bin: [[: not found
-e
-e Aborting.

chmod u=rwx genymotion-2.3.1_x64_debian.bin

$ ./genymotion-2.3.1_x64_debian.bin

Installing to folder [/home/myfolder/Downloads/genymotion]. Are you sure [y/n] ? y


- Trying to find VirtualBox toolset .................... OK (Valid version of VirtualBox found: 4.3.0r89960)
- Extracting files ..................................... OK (Extract into: [/home/myfolder/Downloads/genymotion])

Installation done successfully.

You can now use these tools from [/home/myfolder/Downloads/genymotion]:
 - genymotion
 - genymotion-shell

./genymotion
bash: ./genymotion: cannot execute binary file
sh genymotion
genymotion: 1: genymotion: Syntax error: "(" unexpected

sudo genymotion
[sudo] password for admin:
sudo: genymotion: command not found

http://tukitanotes.blogspot.in/2014/12/genymotion-on-debian-jessie.html
http://linuxn00.blogspot.in/2014/11/instalando-whatsapp-no-opensuse-131-via.html


genymotion $ ls

As was obvious to expect from the output does not have a version 2.15 or higher of the GNU libc genymotion therefore can not serve ...


http://mirror1.jarfil.net/androvm.org/Download/
crypto            icons                       libavutil.so.51   libQtNetwork.so.4  libssl.so        translations
device-upgrade    imageformats                libcrypto.so      libQtScript.so.4   libswscale.so.2
genymotion        lib64EGL_translator.so      libprotobuf.so.7  libQtSql.so.4      player
genymotion-shell  lib64GLES_CM_translator.so  libqca.so.2       libQtSvg.so.4      plugins
genymotion-tool   lib64GLES_V2_translator.so  libQtCore.so.4    libQtWebKit.so.4   sqldrivers
genyshell         lib64OpenglRender.so        libQtGui.so.4     libQtXml.so.4      tools

No comments:

Post a Comment