Friday, May 6, 2011

installing the Adobe Flash Plugin in freebsd

summary - comments show that there are a lot of problems installing adobe flash on freebsd

Download current Flash Player releases


• 10.2.159.1 (Windows, Mac, Linux, Solaris)

http://www.adobe.com/devnet/flashplayer.html

the adobe help searches are so outdated 2006-07-08
http://community.adobe.com/help/search.html?q=freebsd+flash&lbl=0&hl=en_US&lr=en_US&self=1&area=0


This is so outdated . The FAQ is still not updated from 7.X
The Adobe® Flash™ plugin is not available for FreeBSD. However, a software layer (wrapper) for running the Linux version of the plugin exists. This wrapper also supports Adobe Acrobat® plugin, RealPlayer® plugin and more.

According to the version of FreeBSD you run various steps are required:

Under FreeBSD 7.X

Install the www/nspluginwrapper port. This port requires emulators/linux_base-fc4 which is a large port.

The next step is to install the www/linux-flashplugin9 port. This will install Flash 9.X, this version is known to run correctly under FreeBSD 7.X.

Note: On FreeBSD versions older than FreeBSD 7.1-RELEASE you have to install www/linux-flashplugin7 and skip the linprocfs(5) part below.

http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/desktop-browsers.html

No comments:

Post a Comment