Tuesday, October 12, 2010

error installing mylyn and pydev in eclipse on ubuntu 10.04

An error occurred while installing the items
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.eclipse.cvs 1.0.400.v201002111343, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
The artifact file for osgi.bundle,org.eclipse.cvs,1.0.400.v201002111343 was not found.


An error occurred while installing the items
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.eclipse.cvs 1.0.400.v201002111343, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
Cannot connect to keystore.
This trust engine is read only.
The artifact file for osgi.bundle,org.eclipse.cvs,1.0.400.v201002111343 was not found.


An error occurred while installing the items
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.eclipse.cvs 1.0.400.v201002111343, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
The artifact file for osgi.bundle,org.eclipse.cvs,1.0.400.v201002111343 was not found.


You have to install the eclipse-pde, jdt and plugin-cvs packages before installing subversive. If you installed eclipse from the SoftwareCentre, it has not included all of these packages. If you use synaptic and search you will see these missing packages and can install from there.

eclipse-pde plugin development environment
Hi! The installation by the Ubuntu Software Store does not include these packages for Eclipse.
Remove it, and install the Eclipse from Synaptic.
java development tools JDT

I installed Eclipse throught Software Center, installed:

sudo apt-get install eclipse-jdt
sudo apt-get install eclipse-plugin-cvs
sudo apt-get install eclipse-pde

http://www.eclipse.org/forums/index.php?t=msg&goto=531456&
https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/454819



"Mylyn Task List (Required)" is not applicable to the current configuration and will not be installed.
"Mylyn Task-Focused Interface (Recommended)" is not applicable to the current configuration and will not be installed.
"Mylyn WikiText" is not applicable to the current configuration and will not be installed.
"Mylyn Connector: Bugzilla" is not applicable to the current configuration and will not be installed.
"Mylyn Bridge: Eclipse IDE" is not applicable to the current configuration and will not be installed.
"Mylyn Connector: Trac" is not applicable to the current configuration and will not be installed.
"Mylyn Bridge: Plug-in Development" is not applicable to the current configuration and will not be installed.
"Mylyn Bridge: Java Development" is not applicable to the current configuration and will not be installed.
"Mylyn Bridge: C/C++ Development" is not applicable to the current configuration and will not be installed.
"Mylyn Bridge: Team Support" is not applicable to the current configuration and will not be installed.
"Mylyn SDK" is not applicable to the current configuration and will not be installed.
"Mylyn WikiText SDK" is not applicable to the current configuration and will not be installed.
http://wiki.eclipse.org/Mylyn/User_Guide#Installation

Installation Troubleshooting on Eclipse 3.4 and later

Ensure that all required update sites are enabled under Help > Software Updates > Available Software > Manage Sites:

* http://download.eclipse.org/tools/mylyn/update/e3.4
* http://download.eclipse.org/tools/mylyn/update/extras
* http://download.eclipse.org/tools/mylyn/update/incubator

Then follow these steps:

1. Use Help > Software Update > Update to ensure that the latest version of all features is installed
2. Install again
3. If Install fails with a "No repository found containing..." message, remove and re-add the update site that hosts the feature for which the download is failing
4. Install again
5. If the update fails with a "Cannot complete the request..." message, uninstall Mylyn and all Mylyn dependencies
6. Install again

http://wiki.eclipse.org/Mylyn/FAQ#General_Installation_Troubleshooting


I’ve installed Mylyn ; why can’t I see anything different?

The two most likely possibilities are:

1. You don’t have any Mylyn views open. Select Window → Show View → Other, then select Mylyn and you should see the available Mylyn Views.
2. If you still don’t see anything, then perhaps you aren’t using the JDK1.5 VM (or later). See configuring Java.

starting a new pydev project
Choose File > New > Project. From there,
you can select Pydev > Pydev Project.

it will ask you to configure system PYTHONPATH

Use /usr/bin/python

when you do that it will give you an auto list which gets added to the system PYTHONPATH

and shows as name python path /usr/bin/python2.6 (even though you entered just python earlier)
http://pydev.org/manual_101_interpreter.html
http://pydev.blogspot.com/2006/09/configuring-pydev-to-work-with-django.html

this kind of project is associated with the python perspective

No comments:

Post a Comment